Navigation indicator

Default PHP version to be changed to 5.6 on December 1, 2018

November 1, 2018

In the coming months cPanel will be discontinuing their current web stack, in use on our Lockhart, Malfoy, Sirius and Snape servers, in favour of a new, modular system that allows for easy, automatic upgrades of its many components.

We have been preparing for this change for many months, planning the best way to proceed to minimize the impact to our customers. After much testing we have created an upgrade plan that we feel will be the easiest for our customers and introduce the least amount of changes.

On December 1, 2018, all customers who have their PHP version set to our “Native” or default version of PHP will be switched to our alternate, hardened version of PHP 5.6 that is supplied by our operating system and security vendor, CloudLinux.

Customers using Native PHP on our Lockhart, Malfoy and Sirius servers will see their PHP versions changed from 5.4 to 5.6. Customers on our Snape server will remain on PHP 5.6, but will be switched from cPanel’s Native PHP version to CloudLinux’s hardened version of PHP 5.6.

This change will only impact customers who have their PHP version set to “Native” on our Lockhart, Malfoy, Sirius and Snape servers. If you have previously changed your PHP version from Native PHP to an alternate version, you will remain on your current PHP version and will not be affected by this change.

As we have offered customers the ability to change their PHP version from cPanel for many years, you can feel free to make this change in advance of December 1st if you’d like to test your website running under PHP 5.6, or even with newer versions like PHP 7.2 which offers significant performance improvements over PHP 5.

Customers on our Lockhart, Malfoy and Sirius servers can also change to our hardened version of PHP 5.4 if you wish keep your PHP version the same as you are currently using.

To make this change in advance of December 1st, please follow this guide to change your PHP version from your cPanel control panel, or contact our Support department and we’d be happy to apply this change for you.

Once all customers are switched off of Native PHP on December 1st, we will then schedule the upgrade to cPanel’s new, modular web stack at a later date in December.

If you have any questions or concerns, please feel free to contact our Support department for assistance.

Permalink

Changes to Default Options for Alternative PHP Versions

November 1, 2018

To prepare our servers for upcoming web stack upgrades, the following changes have been applied to our default PHP options for alternative PHP versions.

These changes only affect customers who have changed their PHP version from “Native” to an alternate PHP version on our Lockhart, Malfoy, Sirius and Snape servers.

allow_url_fopen = Off (previously On)
date.timezone = America/Regina (previously undefined)
disable_functions = exec, passthru, popen, proc_open, shell_exec, show_source, system (previously undefined)
max_input_time = 60 (previously -1)
post_max_size = 64M (previously 8M)
upload_max_filesize = 32M (previously 2M)

All of these options are user configurable and can be changed from within cPanel.

Permalink